Practical 4: Simulating Simple BGP
Advance Computer Network MSc IT Part 1 Practicals
Network Topology
Configuring IP addresses on all the interfaces
Router R1
Router R2
Router R3
Router R4
Configuring BGP between R1 and R2 on AS1
On Router R1
On Router R2
Configuring BGP between R2 and R3 on AS1 and AS2 respectively
On Router R2
On Router R3
Configuring BGP between R3 and R4 on AS2
On Router R3
On router R4
Verifying the network
R2
On R1
We could successfully reach to router R4 on AS2
On R3
On R4
We ping router R1 on AS 1
Advance Computer Network MSc IT Part 1 Practicals
Network Topology
Configuring IP addresses on all the interfaces
Router R1
Router(config)#int f1/0
Router(config-if)#ip add 192.168.0.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#
Router(config-if)#ip add 192.168.0.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#
Router R2
R2(config)#int f1/0
R2(config-if)#ip add 192.168.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f1/1
R2(config-if)#ip add 10.0.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#
R2(config-if)#ip add 192.168.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f1/1
R2(config-if)#ip add 10.0.0.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#
Router R3
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f1/0
Router(config-if)#ip add 10.0.0.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int f1/1
Router(config-if)#ip add 192.168.100.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f1/0
Router(config-if)#ip add 10.0.0.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int f1/1
Router(config-if)#ip add 192.168.100.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#
Router R4
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f1/0
Router(config-if)#ip add 192.168.100.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f1/0
Router(config-if)#ip add 192.168.100.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Configuring BGP between R1 and R2 on AS1
On Router R1
Router(config)#router bgp 1
Router(config-router)#neighbor 192.168.0.1 remote-as 1
Router(config-router)#exit
Router(config)#
Router(config-router)#neighbor 192.168.0.1 remote-as 1
Router(config-router)#exit
Router(config)#
On Router R2
R2(config-router)#exit
R2(config)#router bgp 1
R2(config-router)#neighbor 192.168.0.2 remote-as 1
R2(config-router)#neighbor 192.168.0.2 next-hop
R2(config-router)#neighbor 192.168.0.2 next-hop-self
R2(config)#router bgp 1
R2(config-router)#neighbor 192.168.0.2 remote-as 1
R2(config-router)#neighbor 192.168.0.2 next-hop
R2(config-router)#neighbor 192.168.0.2 next-hop-self
Configuring BGP between R2 and R3 on AS1 and AS2 respectively
On Router R2
R2(config)#router bgp 1
R2(config-router)#network 192.168.0.0 mask 255.255.255.0
R2(config-router)#neighbor 10.0.0.2 remote-as 2
R2(config-router)#exit
R2(config)#
R2(config-router)#network 192.168.0.0 mask 255.255.255.0
R2(config-router)#neighbor 10.0.0.2 remote-as 2
R2(config-router)#exit
R2(config)#
On Router R3
Router(config)#router bgp 2
Router(config-router)#neighbor 10.0.0.1 remote-as 1
Router(config-router)#network 192.168.100.0 mask 255.255.255.0
Router(config-router)#
Router(config-router)#neighbor 10.0.0.1 remote-as 1
Router(config-router)#network 192.168.100.0 mask 255.255.255.0
Router(config-router)#
Configuring BGP between R3 and R4 on AS2
On Router R3
Router(config)#router bgp 2
Router(config-router)#neighbor 192.168.100.2 remote-as 2
Router(config-router)#neighbor 192.168.100.2 next-hop-self
Router(config-router)#
Router(config-router)#neighbor 192.168.100.2 remote-as 2
Router(config-router)#neighbor 192.168.100.2 next-hop-self
Router(config-router)#
On router R4
R4(config)#router bgp 2
R4(config-router)#neighbor 192.168.100.1 remote-as 2
R4(config-router)#exit
R4(config)#
R4(config-router)#neighbor 192.168.100.1 remote-as 2
R4(config-router)#exit
R4(config)#
Verifying the network
R2
R2#show ip bgp
R2#show ip bgp summary
R2#show ip bgp summary
On R1
We could successfully reach to router R4 on AS2
On R3
R3#show ip bgp neighbors
On R4
We ping router R1 on AS 1
0 comments:
Confused? Feel free to ask
Post a Comment