Thursday 29 May 2014


Practical 7: Simulating EBGP
Advance Computer Network MSc IT Part 1 Practicals

Network Topology


Router R1
R1(config-if)#int f1/0
R1(config-if)#ip add 192.168.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config-if)#int  loopback0
R1(config-if)#ip  add 1.1.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#
Adding bgp adjacencies between AS1 and AS2 and advertising the loopback interface
R1(config)#router bgp 1
R1(config-router)#neighbor 192.168.12.2 remote-as 2
R1(config-router)#exit
R1(config)#router bgp 1
R1(config-router)#network 1.1.1.0 mask 255.255.255.0
R1(config-router)#network 192.168.12.0 mask 255.255.255.0
R1(config-router)#exit





Router R2
R2(config)#int f1/0
R2(config-if)#ip add 192.168.12.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f1/1
R2(config-if)#ip add 192.168.23.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int loopback0
R2(config-if)#ip add 2.2.2.2 255.255.255.0
R2(config-if)#exit

Adding bgp adjacencies between AS1 and AS2 and advertising the loopback interface
R2(config)#router bgp 2
R2(config-router)#neighbor 3.3.3.3 remote-as 3
R2(config-router)#neighbor 3.3.3.3 update-source loopback 0
R2(config-router)#neighbor 3.3.3.3 ebgp-multihop 2
R2(config)#router bgp 2
R2(config-router)#network 2.2.2.0 mask 255.255.255.0
R2(config-router)#network 192.168.23.0
R2(config-router)#exit






Router R3
R3#en
R3#conf t
R3(config)#int f1/0
R3(config-if)#ip add 192.168.23.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#
R3(config)#int f1/1
R3(config-if)#ip add 192.168.34.3 255.255.255.0.
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int loopback0
R3(config-if)#ip add 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#

Adding bgp adjacencies loopback interfaces of AS2 and AS3 and AS3 and AS4 and advertising the loopback interface
R3(config)#router bgp 3
R3(config-router)#neighbor 2.2.2.2 remote-as 2
R3(config-router)#neighbor 2.2.2.2 update-source loopback 0
R3(config-router)#neighbor 2.2.2.2 ebgp-multihop 2
R3(config-router)#neighbor 192.168.34.4 remote-as 4
R3(config-router)#network 3.3.3.3 mask 255.255.255.0
R3(config-router)#network 3.3.3.0 mask 255.255.255.0
R3(config-router)#




Router R4
R4(config)#int f1/0
R4(config-if)#ip add 192.168.34.4 255.255.255.0
R4(config-if)#no shut
R4(config-if)#exit
Adding bgp adjacencies between AS3 and AS4 and advertising the loopback interface
R4(config)#router bgp 4
R4(config-router)#neighbor 192.168.34.3 remote-as 3
R4(config-router)#exit
R4(config)#router bgp 4
R4(config-router)#neighbor 192.168.34.3 remote-as 3
R4(config-router)#network 4.4.4.0 mask 255.255.255.0
R4(config-router)#network 192.168.34.0 mask 255.255.255.0
R4(config-router)#exit
R4(config)#




Verifying the connection
From R1
R1#show ip bgp



#show bgp neighbors



From R3
R3#show ip bgp summary


Testing network reachability
R1#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/8 ms
R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 12/24/36 ms
R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/80 ms
R1#ping 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/60/84 ms
R1#



R4#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/52/80 ms
R4#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/32/48 ms
R4#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/26/44 ms
R4#ping 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms
R4#




Related Posts :



0 comments:

Confused? Feel free to ask

Post a Comment